On Tue, Aug 27, 2024 at 05:15:08AM GMT, Christoph Hellwig wrote: > > + * We are redifining here so we don't need to keep libattr as a dependency anymore > > > +#define ATTR_ENTRY(buffer, index) \ > > Maybe add a XFS_ prefix to distinguish this from the attrlist one > and match the other xfs_ prefixes? Sounds good, will update it. > > > + ((struct xfs_attrlist_ent *) \ > > + &((char *)buffer)[ ((struct xfs_attrlist *)(buffer))->al_offset[index] ]) > > And maybe this really should be an inline function as well. > > > + struct xfs_attrlist *attrlist = (struct xfs_attrlist *)attrbuf; > > Overly long line > > Otherwise this looks good. Thanks for the review, I'll wait for darrick to take a look and will send a V2 Carlos