On Sun, Dec 06, 2020 at 03:11:09PM -0800, Darrick J. Wong wrote: > From: Darrick J. Wong <darrick.wong@xxxxxxxxxx> > > Refactor all the open-coded validation of file block ranges into a > single helper, and teach the bmap scrubber to check the ranges. > > Signed-off-by: Darrick J. Wong <darrick.wong@xxxxxxxxxx> > --- > fs/xfs/libxfs/xfs_bmap.c | 2 +- > fs/xfs/libxfs/xfs_types.c | 25 +++++++++++++++++++++++++ > fs/xfs/libxfs/xfs_types.h | 3 +++ > fs/xfs/scrub/bmap.c | 4 ++++ > fs/xfs/xfs_bmap_item.c | 2 +- > fs/xfs/xfs_rmap_item.c | 2 +- > 6 files changed, 35 insertions(+), 3 deletions(-) Looks fine. Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx> -- Dave Chinner david@xxxxxxxxxxxxx