Hi all, While reviewing the "strengthen log intent validation" series, Brian Foster suggested that we should refactor all the validation code that checks physical extents into a common helper, so I've done that for both data and rt volume mappings. I also did the same for file ranges, since those were kind of a mess of open-coded stuff. Dave Chinner also asked to rename xfs_fc -> xfs_fs so that's the last patch. If you're going to start using this mess, you probably ought to just pull from my git trees, which are linked below. This is an extraordinary way to destroy everything. Enjoy! Comments and questions are, as always, welcome. --D kernel git tree: https://git.kernel.org/cgit/linux/kernel/git/djwong/xfs-linux.git/log/?h=refactorings-5.11 --- fs/xfs/libxfs/xfs_bmap.c | 23 ++++------------ fs/xfs/libxfs/xfs_types.c | 64 ++++++++++++++++++++++++++++++++++++++++++++ fs/xfs/libxfs/xfs_types.h | 7 +++++ fs/xfs/scrub/bmap.c | 17 ++++-------- fs/xfs/scrub/rtbitmap.c | 4 +-- fs/xfs/xfs_bmap_item.c | 13 +-------- fs/xfs/xfs_extfree_item.c | 11 +------- fs/xfs/xfs_refcount_item.c | 11 +------- fs/xfs/xfs_rmap_item.c | 13 +-------- fs/xfs/xfs_super.c | 26 +++++++++--------- 10 files changed, 103 insertions(+), 86 deletions(-)