On Wed, Feb 26, 2020 at 04:14:29PM +0100, Christoph Hellwig wrote: > On Wed, Feb 26, 2020 at 12:03:11PM +1100, Dave Chinner wrote: > > > @@ -59,7 +59,8 @@ typedef struct xfs_da_args { > > > uint8_t filetype; /* filetype of inode for directories */ > > > void *value; /* set of bytes (maybe contain NULLs) */ > > > int valuelen; /* length of value */ > > > - int flags; /* argument flags (eg: ATTR_NOCREATE) */ > > > + unsigned int attr_filter; /* XFS_ATTR_{ROOT,SECURE} */ > > > + unsigned int attr_flags; /* XATTR_{CREATE,REPLACE} */ > > > > At this point, these are really operation flags. I would have named > > the variable attr_opflags but I don't think it's worth redoing the > > entire patch and others over this. > > I've renamed it for the next spin together with the other suggstion. > I'll also add tracing for the opflags. Actually. We already have a op_flags in da_args which is different, so this might and up being rather confusing.