On Tue, 2010-12-28 at 08:16 +0200, ext Arik Nemtsov wrote: > >> diff --git a/drivers/net/wireless/wl12xx/init.h > b/drivers/net/wireless/wl12xx/init.h > >> index 7762421..4d37210 100644 > >> --- a/drivers/net/wireless/wl12xx/init.h > >> +++ b/drivers/net/wireless/wl12xx/init.h > >> @@ -27,10 +27,13 @@ > >> #include "wl12xx.h" > >> > >> int wl1271_hw_init_power_auth(struct wl1271 *wl); > >> -int wl1271_init_templates_config(struct wl1271 *wl); > >> +int wl1271_sta_init_templates_config(struct wl1271 *wl); > >> int wl1271_init_phy_config(struct wl1271 *wl); > >> int wl1271_init_pta(struct wl1271 *wl); > >> int wl1271_init_energy_detection(struct wl1271 *wl); > >> int wl1271_hw_init(struct wl1271 *wl); > >> > >> +/* Functions from wl1271_main.c */ > >> +u32 wl1271_min_rate_get(struct wl1271 *wl); > >> + > > > > This is bad and shouldn't be here. Need to find a better place for > it. > > How about tx.h? It's TX rate we're talking about here after all. > I can also change the name to wl1271_tx_min_rate_get(). Sounds good. -- Cheers, Luca. -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html