On Sun, 2008-12-07 at 18:32 +0100, Henning Rogge wrote: > I think the suggestion is to remove the total/legacy bitrate for 802.11n > completely from the nl80211 station_info. Which I still think is not a good > idea. This way we force any application displaying the bitrate to check for > several cases, know about the 802.11n table, ... > I think it's funny that we have the "total bitrate" information available on > driver level but translate it into the mcs index with the help of tables... > and assume that userspace knows about the tables. Alright, whatever, put it in, but please do the calculation in cfg80211 (nl80211.c). Should rename it to _TOTAL again then, though, I guess. > /** > + * enum nl80211_sta_info_rate - station information about bitrate > + * > + * These attribute types are used with %NL80211_STA_INFO_TXRATE > + * when getting information about the bitrate of a station. > + * > + * @__NL80211_STA_INFO_RATE_INVALID: attribute number 0 is reserved > + * @NL80211_STA_INFO_RATE_LEGACY: bitrate for 802.11abg (u16, 100kbit/s) > + * @NL80211_STA_INFO_RATE_MCS: mcs index for 802.11n (u8) > + * @NL80211_STA_INFO_RATE_40_MHZ_WIDTH: 40 Mhz dualchannel bitrate > + * @NL80211_STA_INFO_RATE_SHORT_GI: 400ns guard interval > + */ > +enum nl80211_sta_info_rate { > + __NL80211_STA_INFO_RATE_INVALID, > + NL80211_STA_INFO_RATE_LEGACY, > + NL80211_STA_INFO_RATE_MCS, > + NL80211_STA_INFO_RATE_40_MHZ_WIDTH, > + NL80211_STA_INFO_RATE_SHORT_GI, > + > + /* keep last */ > + __NL80211_STA_INFO_RATE_AFTER_LAST, > + NL80211_STA_INFO_RATE_MAX = __NL80211_STA_INFO_RATE_AFTER_LAST - 1 > +}; Can you rename those too to NL80211_RATE_INFO_*? That way we can use them for other things later. But this looks good to me now. johannes
Attachment:
signature.asc
Description: This is a digitally signed message part