Anuj Khera <quic_akhera@xxxxxxxxxxx> writes: > The cfg80211_pmksa structure uses bssid member to store > the PMKSA for a BSS in Station mode. Change the name of > structure member bssid to peer_addr so that same member > can be used to store the PMKSA for a station in AP mode > using station MAC address. > > Signed-off-by: Anuj Khera <quic_akhera@xxxxxxxxxxx> > --- > drivers/net/wireless/ath/ath6kl/cfg80211.c | 8 ++++---- > .../wireless/broadcom/brcm80211/brcmfmac/cfg80211.c | 12 ++++++------ > drivers/net/wireless/microchip/wilc1000/cfg80211.c | 10 +++++----- > drivers/staging/rtl8723bs/os_dep/ioctl_cfg80211.c | 8 ++++---- > include/net/cfg80211.h | 5 +++-- > net/wireless/nl80211.c | 2 +- > net/wireless/trace.h | 2 +- > net/wireless/wext-compat.c | 2 +- > 8 files changed, 25 insertions(+), 24 deletions(-) For a rename like this I would expect to see patch 2 adding the actual functionality. Johannes, just so you know this patch has nothing to do with ath10k/ath11k/ath12k. I guess this is for the proprietary Qualcomm driver? -- https://patchwork.kernel.org/project/linux-wireless/list/ https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches