On Wednesday 05 November 2008 13:40:22 Johannes Berg wrote: > On Wed, 2008-11-05 at 13:38 -0200, Herton Ronaldo Krzesinski wrote: > > > > WARNING: line over 80 characters > > > > #138: FILE: drivers/net/wireless/rtl8187_dev.c:475: > > > > + if ((le16_to_cpu(ieee80211hdr->seq_ctrl) & > > > > 0xFFF) == seq_no) > > > > Ops, I forgot to run checkpatch.pl here, will run and fix it when I > > submit next patch. > > I wouldn't worry about lines > 80 chars too much, breaking this down > wouldn't make more readable but less so, in my opinion. I tend to ignore > that rule where it makes the code unreadable :) > > > > Besides, that line looks wrong? the lowest 4 bits are teh fragment > > > number. > > > > It's intended, because the hardware instead of reporting just the > > sequence number in its 12 bits is reporting fragment number + sequence > > number, this is a workaround. > > Ah. A comment might be appropriate that "seq_no" doesn't actually > contain the sequence number? Yes, I'll improve comment there, will change by this: /* * While testing, it was discovered that the seq_no doesn't * actually contains the sequence number. Instead * of returning just the 12 bits of sequence number, * hardware is returning entire sequence control (fragment * number plus sequence number) in a 12 bit only field * overflowing after some time. As a workaround, * just consider the lower bits, and expect it's unlikely * we wrongly ack some sent data */ > > johannes -- []'s Herton -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html