On Sun, Sep 7, 2008 at 1:25 AM, Johannes Berg <johannes@xxxxxxxxxxxxxxxx> wrote: > >> >> +static void ieee80211_set_disassoc(struct ieee80211_sub_if_data *sdata, >> + struct ieee80211_if_sta *ifsta, int deauth, >> + int self_disconnected, u16 reason) > > I think you should use bool for those two (deauth, self) I'm thinking rather using some enum values just for readability foo(DEAUTH, ORIGIN_SELF) vs foo(tree,true) foo(DISASSOC, ORIGIN_PEER) vs foo(false, false) >> + rcu_read_unlock(); >> + >> + sta_info_unlink(&sta); > > Those need to be the other way around. Will do, Thanks Tomas -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html