On Thursday 19 June 2008 19:20:16 Harvey Harrison wrote: > > #define CALL_RXH(rxh) if ((res = rxh(rx)) != RX_CONTINUE) goto rxh_done; > > Would it really be so bad to just open-code them rather than the macro approach? I think the macro makes it readable. And as it is defined locally it does not obfuscate it. > res = ieee80211_rx_h_passive_scan(rx); > if (res != RX_CONTINUE) goto rxh_done; This would most likely need to look like this, if opencoded: res = ieee80211_rx_h_passive_scan(rx); if (res != RX_CONTINUE) goto rxh_done; > > res = ieee80211_rx_h_check(rx); > if (res != RX_CONTINUE) goto rxh_done; > > ... > -- Greetings Michael. -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html