Search Linux Wireless

Re: [RFC 3/2] get rid of rx handler function pointers

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, 2008-06-19 at 19:44 +0200, Michael Buesch wrote:
> On Thursday 19 June 2008 19:20:16 Harvey Harrison wrote:
> > > #define CALL_RXH(rxh) if ((res = rxh(rx)) != RX_CONTINUE) goto rxh_done;
> > 
> > Would it really be so bad to just open-code them rather than the macro approach?
> 
> I think the macro makes it readable. And as it is defined locally it
> does not obfuscate it.

We can always make the macro more readable:

#define CALL_RXH(rxh)		\
	res = rxh(rx);		\
	if (res != RX_CONTINUE)	\
		goto rxh_done;

johannes

Attachment: signature.asc
Description: This is a digitally signed message part


[Index of Archives]     [Linux Host AP]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [Linux Kernel]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Samba]     [Device Mapper]
  Powered by Linux