> > #define CALL_RXH(rxh) if ((res = rxh(rx)) != RX_CONTINUE) goto rxh_done; > > Would it really be so bad to just open-code them rather than the macro approach? > > res = ieee80211_rx_h_passive_scan(rx); > if (res != RX_CONTINUE) goto rxh_done; > > res = ieee80211_rx_h_check(rx); > if (res != RX_CONTINUE) goto rxh_done; > > ... > > > Similar comment for the transmit handler patch. Well, I was lazy, and figured it'd be easier to add new ones that way if needed. > Either way, the approach looks good, > and the size reduction is nice. :) johannes
Attachment:
signature.asc
Description: This is a digitally signed message part