Johannes Berg <johannes@xxxxxxxxxxxxxxxx> writes: >> Yeah, was going to do that anyway. But since I'm touching the code >> anyway, this might be an opportunity to avoid constructs like this: >> >> if (!invoke_tx_handlers(tx)) >> /* continue sending the packet */ >> >> Most other succeed/fail functions seem to be of type bool, so it >> would help consistency as well. Unless there is some particular >> reason why this function happens to be using 0 to indicate success? >> > > It's just convention in the kernel, really. > > IMHO if a function has a bool return value it should be have a more > expressive name that indicates better what's going on, like e.g. > > bool ieee80211_is_radar_required(...); > > but of course that's not always done. Well, it's applied somewhat inconsistently across mac80211, it seems (e.g. ieee80211_tx() and ieee80211_tx_prepare_skb() are bool, while invoke_tx_handlers() and ieee80211_skb_resize() are int). But okay, don't have that strong an opinion about the colour of this particular bikeshed so I'll keep it the way it is ;) -Toke