Michal Kazior <michal.kazior@xxxxxxxxx> writes: >> Even though this is correct, I think it's still a bit evil. For example, >> I missed '!' the first time I looked at this. Even this is a line >> longer, I think it would be easier to read: >> >> WARN_ON(ar->num_started_vdevs == 0); >> >> if (ar->num_started_vdevs != 0) { >> ... >> } > > Sound reasonably. I changed it like this now: --- a/drivers/net/wireless/ath/ath10k/mac.c +++ b/drivers/net/wireless/ath/ath10k/mac.c @@ -878,7 +878,9 @@ static int ath10k_vdev_stop(struct ath10k_vif *arvif) return ret; } - if (!WARN_ON(ar->num_started_vdevs == 0)) { + WARN_ON(ar->num_started_vdevs == 0); + + if (ar->num_started_vdevs != 0) { ar->num_started_vdevs--; ath10k_recalc_radar_detection(ar); Full patch here: https://github.com/kvalo/ath/commit/0d57ff8b99539895c5a3714d7ecd80a58b6a8928 -- Kalle Valo -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html