Hi Stanislaw Gruszka wrote: > +static void rt2800_init_rfcsr_305x_soc(struct rt2x00_dev *rt2x00dev) > +{ > + rt2800_rfcsr_write(rt2x00dev, 0, 0x50); > + rt2800_rfcsr_write(rt2x00dev, 1, 0x01); > + rt2800_rfcsr_write(rt2x00dev, 2, 0xf7); > + rt2800_rfcsr_write(rt2x00dev, 3, 0x75); > + rt2800_rfcsr_write(rt2x00dev, 4, 0x40); > + rt2800_rfcsr_write(rt2x00dev, 5, 0x03); > + rt2800_rfcsr_write(rt2x00dev, 6, 0x02); > + rt2800_rfcsr_write(rt2x00dev, 7, 0x50); Wouldn't a table based initialization be more readable and also shorter? Dave -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html