Hi guys, So this would the first step where otg_transceiver is first renamed to usb_transceiver and OTG stuff is separated into new structure, struct otg. I would have preferred introducing the new things separately without touching the existing and letting driver maintainers to start using them in their own time, but if this is the way it should be done, then here you go. The First two patches rename otg_transceiver and introduce struct otg. The otg/transceiver drivers are converted each in it's own patch, but the users are converted in singe patches, first to change the transceiver specific function names and then to pass the struct otg instead of usb_transceiver to otg_* functions. The naming needs to be decided. usb_transceiver is indeed a long name, but I'm not completely happy with usb_xceiv name. I would prefer usb_phy. To me it is somehow more clear as some of the drivers are not exactly for transceivers, like the gpio_vbus, and some of the operations may be handled by some other hw then the transceiver in some cases. Please comment if you guys are OK or not with these, and if this is the way you prefer or not. After this, the second step would be to support multiple transceivers, and splitting the utility into otg and something like "phy" utility. Br, heikki Heikki Krogerus (17): usb: otg: Rename otg_transceiver to usb_transceiver usb: otg: Separate otg members from usb_transceiver usb: otg: ab8500: Start using struct otg usb: otg: fsl: Start using struct otg usb: otg: gpio_vbus: Start using struct otg usb: otg: isp1301_omap: Start using struct otg usb: otg: msm: Start using struct otg usb: otg: langwell: Start using struct otg usb: otg: nop: Start using struct otg usb: otg: twl4030: Start using struct otg usb: otg: twl6030: Start using struct otg usb: otg: ulpi: Start using struct otg arm: imx: Start using struct otg power_supply: Convert all users to new usb_transceiver usb: Convert all user to new usb_transceiver usb: otg: Remove OTG specific members from usb_transceiver usb: otg: Convert all users to pass struct otg for OTG functions arch/arm/mach-imx/mx31moboard-devboard.c | 8 +- arch/arm/mach-imx/mx31moboard-marxbot.c | 8 +- arch/arm/mach-pxa/pxa3xx-ulpi.c | 20 +- arch/arm/mach-tegra/include/mach/usb_phy.h | 2 +- arch/arm/plat-mxc/include/mach/ulpi.h | 6 +- arch/arm/plat-mxc/ulpi.c | 8 +- drivers/power/isp1704_charger.c | 108 +++++---- drivers/power/pda_power.c | 8 +- drivers/power/twl4030_charger.c | 20 +- drivers/usb/gadget/ci13xxx_msm.c | 4 +- drivers/usb/gadget/ci13xxx_udc.c | 17 +- drivers/usb/gadget/ci13xxx_udc.h | 2 +- drivers/usb/gadget/fsl_udc_core.c | 9 +- drivers/usb/gadget/fsl_usb2_udc.h | 2 +- drivers/usb/gadget/langwell_udc.c | 12 +- drivers/usb/gadget/langwell_udc.h | 2 +- drivers/usb/gadget/omap_udc.c | 25 +- drivers/usb/gadget/omap_udc.h | 2 +- drivers/usb/gadget/pxa25x_udc.c | 13 +- drivers/usb/gadget/pxa25x_udc.h | 2 +- drivers/usb/gadget/pxa27x_udc.c | 11 +- drivers/usb/gadget/pxa27x_udc.h | 2 +- drivers/usb/host/ehci-fsl.c | 6 +- drivers/usb/host/ehci-hub.c | 2 +- drivers/usb/host/ehci-msm.c | 14 +- drivers/usb/host/ehci-mxc.c | 20 +- drivers/usb/host/ehci-tegra.c | 14 +- drivers/usb/host/ehci.h | 2 +- drivers/usb/host/ohci-omap.c | 8 +- drivers/usb/host/ohci.h | 2 +- drivers/usb/musb/am35x.c | 4 +- drivers/usb/musb/blackfin.c | 6 +- drivers/usb/musb/da8xx.c | 4 +- drivers/usb/musb/davinci.c | 6 +- drivers/usb/musb/musb_core.c | 12 +- drivers/usb/musb/musb_core.h | 2 +- drivers/usb/musb/musb_gadget.c | 10 +- drivers/usb/musb/omap2430.c | 28 +- drivers/usb/musb/tusb6010.c | 8 +- drivers/usb/musb/ux500.c | 8 +- drivers/usb/otg/Kconfig | 2 +- drivers/usb/otg/ab8500-usb.c | 90 ++++--- drivers/usb/otg/fsl_otg.c | 117 +++++---- drivers/usb/otg/fsl_otg.h | 2 +- drivers/usb/otg/gpio_vbus.c | 58 +++-- drivers/usb/otg/isp1301_omap.c | 238 ++++++++++--------- drivers/usb/otg/langwell_otg.c | 335 ++++++++++++++------------ drivers/usb/otg/msm_otg.c | 363 ++++++++++++++-------------- drivers/usb/otg/nop-usb-xceiv.c | 66 +++--- drivers/usb/otg/otg.c | 20 +- drivers/usb/otg/otg_fsm.c | 22 +- drivers/usb/otg/otg_fsm.h | 2 +- drivers/usb/otg/twl4030-usb.c | 78 ++++--- drivers/usb/otg/twl6030-usb.c | 114 +++++---- drivers/usb/otg/ulpi.c | 116 +++++---- drivers/usb/otg/ulpi_viewport.c | 6 +- include/linux/usb/intel_mid_otg.h | 8 +- include/linux/usb/msm_hsusb.h | 2 +- include/linux/usb/otg.h | 161 +++++++------ include/linux/usb/ulpi.h | 4 +- 60 files changed, 1197 insertions(+), 1054 deletions(-) -- 1.7.4.1 -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html