Re: [PATCH 1/2] EHCI : introduce a common ehci_setup

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sat, 2 Jul 2011, Matthieu CASTET wrote:

> This allow to clean duplicated code in most of SOC driver.
> 
> Signed-off-by: Matthieu CASTET <castet.matthieu@xxxxxxx>
> ---
>  drivers/usb/host/ehci-hcd.c |   29 +++++++++++++++++++++++++++++
>  1 files changed, 29 insertions(+), 0 deletions(-)
> 
> diff --git a/drivers/usb/host/ehci-hcd.c b/drivers/usb/host/ehci-hcd.c
> index f8030ee..f990b0f 100644
> --- a/drivers/usb/host/ehci-hcd.c
> +++ b/drivers/usb/host/ehci-hcd.c
> @@ -763,6 +763,35 @@ static int ehci_run (struct usb_hcd *hcd)
>  	return 0;
>  }
>  
> +static int __maybe_unused ehci_setup (struct usb_hcd *hcd)
> +{
> +	struct ehci_hcd *ehci = hcd_to_ehci(hcd);
> +	int retval;

...

> +}
> +

Instead of putting this routine in ehci-hcd.c, where it will silently 
use up unnecessary codespace on thousands or millions of desktop 
systems, why not put it into a new separate source file?  Then the SOC 
drivers can #include that file.

Alan Stern

--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux