On Wed, Dec 15, 2010 at 07:39:25PM +0800, Ming Lei wrote:
Hi Felipe,
2010/12/14 Felipe Balbi <balbi@xxxxxx>:
On Tue, Dec 14, 2010 at 12:49:15PM +0800, Ming Lei wrote:
Hi Felipe,
2010/12/13 Felipe Balbi <balbi@xxxxxx>:
hi,
On Mon, Dec 13, 2010 at 09:43:33PM +0800, Ming Lei wrote:
In fact many glue driver used the same default read_fifo/write_fifo, do
you want to duplicate the code many times in this glue drivers?
no, look at the code I put:
/* the below code would be on musb_core.c */
Yes, as said from the comments, musb_read_fifo and musb_write_fifo
are defined in musb_hdrc driver(musb_core.c) now.
Now some of glue drivers need to access the two symbols to use the default
implementation, and other glue drivers have their own
.read_fifo/.write_fifo
implementations. If the two sybmols are not permitted to be exported from
musb_hdrc, the glue drivers which need to access them will have to
duplicate
this two functions into their own drivers, right?
So I think we should allow to export some symbols from musb_hdrc.
You didn't read the code I put on previous mail, did you ?
Sorry, it is really a very tricky method, but we still have the problems
on the functions below:
musb_interrupt/musb_dma_completion/musb_debug/...
so export symbol has fewer changes than your method and
no obvious side effect, isn't it?
I don't like that, but let's see the final patches. Although about
musb_debug, I think we should convert DBG() into dev_dbg() on glue
layers then, intead of printing musb-hdrc they'll print musb-omap2430
and etc, which makes it easier to figure out the problem might be on
glue layer, not on musb :-)
--
balbi
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html