Re: trace/events: DECLARE vs DEFINE semantic

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Mathieu Desnoyers wrote:
> In addition, I wonder if we should rename "CREATE_TRACE_POINTS" to
> something more suitable while we are here ? Basically, it will affect
> all TRACE_CLASS/TRACE_CLASS_EVENT/TRACE_EVENT from headers included
> after it's defined.

Agreed, CREATE_TRACE_POINTS is a bit irritating thing :-(

For example, if we call tracepoints defined in same-header on
several different files, we need to check other people have
already defined CREATE_TRACE_POINTS on another file, because
CREATE_TRACE_POINTS must be used once for each header...

So, how about introducing a c file which is only for defining
tracepoints for kernel parts ? or defining tracepoints in
kernel at the beginning of kernel/tracepoint.c ? (and don't
touch tracepoints in modules)

e.g.

@kernel/tracepoint.c
 ...
 #define CREATE_TRACE_POINTS
 #include <trace/events/sched.h>
 #include <trace/events/...>
 ...

@kernel/sched.c
 ...
 #include <trace/events/sched.h>	/* Just include events header */
 ...

@fs/ext4/super.c (no change, since it can be module)
 ...
 #define CREATE_TRACE_POINTS
 #include <trace/events/ext4.h>
 ...

Hmm?

Thank you,

-- 
Masami Hiramatsu

Software Engineer
Hitachi Computer Products (America), Inc.
Software Solutions Division

e-mail: mhiramat@xxxxxxxxxx

--
To unsubscribe from this list: send the line "unsubscribe linux-tip-commits" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Stable Commits]     [Linux Stable Kernel]     [Linux Kernel]     [Linux USB Devel]     [Linux Video &Media]     [Linux Audio Users]     [Yosemite News]     [Linux SCSI]

  Powered by Linux