This is a collection of random fixes for tty I did while crawling through the code. Mostly done for readability and understandability. No behavior change intended (except for Documentation fixes). Jiri Slaby (SUSE) (15): tty: n_tty: use 'retval' instead of 'c' tty: n_tty: rename and retype 'retval' in n_tty_ioctl() tty: n_tty: use min3() in copy_from_read_buf() tty: n_tty: invert the condition in copy_from_read_buf() tty: n_tty: use do-while in n_tty_check_{,un}throttle() tty: switch tty_{,un}throttle_safe() to return a bool tty: invert return values of tty_{,un}throttle_safe() tty: fix up and plug in tty_ioctl kernel-doc tty: fix kernel-doc for functions in tty.h tty: stop using ndash in kernel-doc tty: tty_buffer: use bool for 'restart' in tty_buffer_unlock_exclusive() tty: convert THROTTLE constants into enum tty: early return from send_break() on TTY_DRIVER_HARDWARE_BREAK tty: don't check for signal_pending() in send_break() tty: use 'if' in send_break() instead of 'goto' Documentation/driver-api/tty/index.rst | 1 + Documentation/driver-api/tty/tty_ioctl.rst | 10 + drivers/tty/n_tty.c | 77 ++++--- drivers/tty/tty.h | 13 +- drivers/tty/tty_buffer.c | 5 +- drivers/tty/tty_io.c | 36 ++-- drivers/tty/tty_ioctl.c | 234 ++++++++++----------- drivers/tty/tty_port.c | 6 +- drivers/tty/vt/consolemap.c | 2 +- drivers/tty/vt/vc_screen.c | 4 +- drivers/tty/vt/vt.c | 4 +- include/linux/tty.h | 25 +-- 12 files changed, 209 insertions(+), 208 deletions(-) create mode 100644 Documentation/driver-api/tty/tty_ioctl.rst -- 2.42.0