This is another part (say part III.) of the previous type unification across the tty layer[1]. This time, in n_tty line discipline. Apart from type changes, this series contains a larger set of refactoring of the code. Namely, separating hairy code into single functions for better readability. [1] https://lore.kernel.org/all/20230810091510.13006-1-jirislaby@xxxxxxxxxx/ Note this is completely independent on "part II." (tty_buffer cleanup), so those two can be applied in any order. [v2] * resend as I intertwined the series with and older one * use better name for variable in 03/14 Jiri Slaby (SUSE) (14): tty: n_tty: make flow of n_tty_receive_buf_common() a bool tty: n_tty: use output character directly tty: n_tty: use 'num' for writes' counts tty: n_tty: use time_is_before_jiffies() in n_tty_receive_overrun() tty: n_tty: make n_tty_data::num_overrun unsigned tty: n_tty: use MASK() for masking out size bits tty: n_tty: move canon handling to a separate function tty: n_tty: move newline handling to a separate function tty: n_tty: remove unsigned char casts from character constants tty: n_tty: simplify chars_in_buffer() tty: n_tty: use u8 for chars and flags tty: n_tty: unify counts to size_t tty: n_tty: extract ECHO_OP processing to a separate function tty: n_tty: deduplicate copy code in n_tty_receive_buf_real_raw() drivers/tty/n_tty.c | 538 +++++++++++++++++++++++--------------------- 1 file changed, 278 insertions(+), 260 deletions(-) -- 2.42.0