Re: [PATCH 2/4] tty: serial: use FIELD_GET() in lqasc_tx_ready()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, 27 Sep 2022, Jiri Slaby wrote:

> FIELD_GET() can do the job smarter and more readable. We don't even need
> ASCFSTAT_TXFREEOFF. So switch to the former and remove the latter.
> 
> Suggested-by: Ilpo Järvinen <ilpo.jarvinen@xxxxxxxxxxxxxxx>
> Signed-off-by: Jiri Slaby <jslaby@xxxxxxx>

Reviewed-by: Ilpo Järvinen <ilpo.jarvinen@xxxxxxxxxxxxxxx>

-- 
 i.

> ---
>  drivers/tty/serial/lantiq.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/tty/serial/lantiq.c b/drivers/tty/serial/lantiq.c
> index ba9739af30ed..c892f3c7d1ab 100644
> --- a/drivers/tty/serial/lantiq.c
> +++ b/drivers/tty/serial/lantiq.c
> @@ -8,6 +8,7 @@
>   * Copyright (C) 2010 Thomas Langer, <thomas.langer@xxxxxxxxxx>
>   */
>  
> +#include <linux/bitfield.h>
>  #include <linux/clk.h>
>  #include <linux/console.h>
>  #include <linux/device.h>
> @@ -93,7 +94,6 @@
>  #define ASCFSTAT_RXFFLMASK	0x003F
>  #define ASCFSTAT_TXFFLMASK	0x3F00
>  #define ASCFSTAT_TXFREEMASK	0x3F000000
> -#define ASCFSTAT_TXFREEOFF	24
>  
>  static void lqasc_tx_chars(struct uart_port *port);
>  static struct ltq_uart_port *lqasc_port[MAXPORTS];
> @@ -143,7 +143,7 @@ static bool lqasc_tx_ready(struct uart_port *port)
>  {
>  	u32 fstat = __raw_readl(port->membase + LTQ_ASC_FSTAT);
>  
> -	return (fstat & ASCFSTAT_TXFREEMASK) >> ASCFSTAT_TXFREEOFF;
> +	return FIELD_GET(ASCFSTAT_TXFREEMASK, fstat);
>  }
>  
>  static void
> 

[Index of Archives]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Linux PPP]     [Linux FS]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Video 4 Linux]     [Linmodem]     [Device Mapper]     [Linux Kernel for ARM]

  Powered by Linux