On 11/22/22 12:38 AM, Christoph Hellwig wrote: > On Mon, Nov 21, 2022 at 09:39:25PM -0600, Mike Christie wrote: >> + result = scsi_execute_cmd(sdev, cmd, REQ_OP_DRV_IN, buffer, >> + request_len, 30 * HZ, 3, >> + ((struct scsi_exec_args) { .sshdr = &sshdr })); > > Maybe it's me, but I hate the syntax to declare structs inside argument I'll change it to setup the scsi_exec_args struct like normal. I've got this comment several times now. With the current design we know all the args when we declare the variables so I can do it then like normal. > list. But even when we go with it, splitting it into multiple lines > would be a lot more readable: > ((struct scsi_exec_args) { > .sshdr = &sshdr, > })); >