Re: [PATCH 06/15] scsi: core: Convert to scsi_execute_cmd

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Nov 21, 2022 at 09:39:25PM -0600, Mike Christie wrote:
> +	result = scsi_execute_cmd(sdev, cmd, REQ_OP_DRV_IN, buffer,
> +				  request_len, 30 * HZ, 3,
> +				  ((struct scsi_exec_args) { .sshdr = &sshdr }));

Maybe it's me, but I hate the syntax to declare structs inside argument
list.  But even when we go with it, splitting it into multiple lines
would be a lot more readable:
				  ((struct scsi_exec_args) {
				  	.sshdr = &sshdr,
				  }));




[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Index of Archives]     [SCSI Target Devel]     [Linux SCSI Target Infrastructure]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Linux IIO]     [Samba]     [Device Mapper]

  Powered by Linux