Hi all, On R-Car SoCs, pin group names usually have a suffix ("_a", "_b", ...) if and only if there are alternate pin groups for the same function. At the time initial pin control support for the R-Car V4H (R8A779G0) SoC was introduced, there were lots of ambiguities and inconsistencies in the naming of pin groups in the documentation, violating this convention: 1. Some alternate pin groups may be named identically, without any suffix to differentiate, 2. In case of two alternate pin groups, the primary may not carry a suffix, while the alternate may carry an "_a" or "_b" suffix, 3. A pin group without an alternate may have an "_a" or even a "_b" suffix. So far the driver followed the documentation, except for case 1, where an "_x" suffix was added to one of the alternates. The plan was to update the pin group names when they were clarified in the documentation. As technically these names are part of the ABI, they were clearly marked with "suffix might be updated" in the driver. Unfortunately the pin group names are still not updated in the latest revision (Rev.1.10) of the R-Car V4H Series Hardware User's Manual. However, the newer R-Car V4M (R8A779H0) SoC is mostly signal-compatible with R-Car V4H (they are not pin-compatible, as R-Car V4H has many more pins). Hence this series bites the bullet, and fixes the ambiguities and inconsistencies by adopting R-Car V4M pin group naming (from Rev.0.51 of the R-Car V4M Series Hardware User's Manual), and following the traditional naming convention. Note that this does not affect any upstream DTS files. Thanks for your comments! Geert Uytterhoeven (8): pinctrl: renesas: r8a779g0: Fix CANFD5 suffix pinctrl: renesas: r8a779g0: Fix FXR_TXEN[AB] suffixes pinctrl: renesas: r8a779g0: Fix (H)SCIF1 suffixes pinctrl: renesas: r8a779g0: Fix (H)SCIF3 suffixes pinctrl: renesas: r8a779g0: Fix IRQ suffixes pinctrl: renesas: r8a779g0: FIX PWM suffixes pinctrl: renesas: r8a779g0: Fix TCLK suffixes pinctrl: renesas: r8a779g0: Fix TPU suffixes drivers/pinctrl/renesas/pfc-r8a779g0.c | 712 ++++++++++++------------- 1 file changed, 348 insertions(+), 364 deletions(-) -- 2.34.1 Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds