On 2/5/2019 6:08 PM, Bart Van Assche wrote:
On Tue, 2019-02-05 at 14:56 +0000, Israel Rukshin wrote:
On 2/5/2019 6:25 AM, Bart Van Assche wrote:
On 2/4/19 9:50 AM, Max Gurtovoy wrote:
+#include <rdma/signature.h>
Do we really need this #include directive in <rdma/ib_verbs.h>? Can
this #include directive be moved into the source files that need it?
Yes, we need this include at <rdma/ib_verbs.h>.
<rdma/ib_verbs.h> uses struct ib_sig_err which is defined at
<rdma/signature.h>.
Hi Israel,
Are you perhaps referring to struct ib_mr_status? It seems to me that that
structure is only used in code that is related to protection information.
Have you considered to move the definition of that structure into
<rdma/signature.h> and add a forward declaration of that structure in
<rdma/ib_verbs.h> instead?
Thanks,
Bart.
Hi Bart,
it's kind of hard to change all ib_verbs.h in one-shot. We're trying to
make things easier and this is why we added the signature.h file.
It need more work and renaming to move ib_mr_status to be signature
specific and I'm not sure it the right thing to do now. I prefer to stay
with the include since we don't really harm anything comparing the
current state.
We just ease the endless ib_verbs.h file and make the code more readable
as we mentioned in the commit message.