These patches clean up and unify the PCI slot configuration across the acpiphp, pciehp, and shpchp drivers. When these drivers detect a newly-added device, they configure the bus. On ACPI systems, this uses PCI bus settings from _HPP or _HPX methods. Previously, each driver handled this separately with similar but not quite identical code. This series adds a single pci_configure_slot() function and changes each driver to use it. Changes from initial post to v2: - use static inline empty function rather than #define for non-ACPI (Eike) - export pci_configure_slot() - add comment about why we don't program default PCI settings for PCIe - tidy up PCIe setting check for PCIe device - move pci_configure_slot() and related functions to acpi_pcihp.c (Kenji) - make acpi_get_hp_params() static --- Bjorn Helgaas (9): PCI hotplug: acpiphp: remove superfluous _HPP/_HPX evaluation PCI hotplug: acpiphp: don't cache hotplug_params in acpiphp_bridge PCI hotplug: rename acpi_get_hp_params_from_firmware() to acpi_get_hp_params() PCI hotplug: add pci_configure_slot() PCI hotplug: pciehp: use generic pci_configure_slot() PCI hotplug: shpchp: use generic pci_configure_slot() PCI hotplug: acpiphp: use generic pci_configure_slot() PCI hotplug: clean up acpi_run_hpp() PCI hotplug: make acpi_get_hp_params() static drivers/pci/hotplug/acpi_pcihp.c | 269 ++++++++++++++++++++++++++---------- drivers/pci/hotplug/acpiphp.h | 3 drivers/pci/hotplug/acpiphp_glue.c | 95 +------------ drivers/pci/hotplug/pciehp.h | 9 - drivers/pci/hotplug/pciehp_pci.c | 132 ------------------ drivers/pci/hotplug/pcihp_slot.c | 0 drivers/pci/hotplug/shpchp.h | 9 - drivers/pci/hotplug/shpchp_pci.c | 62 -------- include/linux/pci_hotplug.h | 5 - 9 files changed, 205 insertions(+), 379 deletions(-) create mode 100644 drivers/pci/hotplug/pcihp_slot.c -- Bjorn -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html