Matthew Wilcox wrote: > On Fri, Apr 17, 2009 at 02:25:13PM -0700, Yinghai Lu wrote: > >> pci_create_bus is only for root bus, and pci_scan_child_bus is called on >> that root bus. >> >> if we moved x86_pci_root_bus_res_quirks calling in pci_scan_child_bus, >> it will be checked with all child buses. >> >> so we'd better to keep that calling in pci_create_bus. >> > > But set_pci_bus_resources_arch_default() already checks that it's being > called for a root bus: > > for (i = 0; i < pci_root_num; i++) { > if (pci_root_info[i].bus_min == b->number) > break; > } > > if (i == pci_root_num) > return; > > > We should have a better name for pci_create_bus and set_pci_bus_resources_arch_default like pci_create_root_bus and set_root_bus_res_arch. YH -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html