[...] >>> 1. Modify the inline access functions to take the PEND and others >>> if needed registers as a parameter >>> >>> 2. Modify mach-omap2/timer.c to initialize the PEND and others >>> in the SoC specific timer_init function Just to make my understanding complete, need some clarifications: As we would end up modifying almost all inline functions, what naming convention should we follow for the parameters? For instance, PEND is related to TWPS register. So are you suggesting using parameter names related to respective registers in each inline functions? If that is the case we would end up declaring lot of local variables along with PEND. Instead, we could very well have just two variables to represent functional and interrupt offsets. Also, in plat-omap/dmtimer.c, timer_regs{} stores the register values and not the register offsets. Therefore, we would not be able to pass as parameters, timer->context.<x> ... etc. Please let me know if I am off-track in my understanding. Thanks. -- Tarun [...] -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html