On 05/12/11 11:47, Janorkar, Mayuresh wrote: >> On 05/12/11 10:16, Igor Grinberg wrote: >> there is a typo in the function name: >> s/ldp_twl_gpio_setup/ldp_twl_gpios_setup/ > Also, >> + }; >> + >> + r = gpio_request_array(twl_gpios, ARRAY_SIZE(gpios)); > This should be ARRAY_SIZE(twl_gpios)); yeah, sorry for that that is what happening when making patches in a hurry and no checks done > And one more thing: > We need to use regulator for OMAP3430. > > > Something like this: > +/* VPLL2 for digital video outputs */ > +static struct regulator_consumer_supply ldp_vpll2_supplies[] = { > + REGULATOR_SUPPLY("vdds_dsi", "omapdss"), > + REGULATOR_SUPPLY("vdds_dsi", "omapdss_dsi1"), > +}; > + > +static struct regulator_init_data ldp_vpll2 = { > + .constraints = { > + .name = "VDVI", > + .min_uV = 1800000, > + .max_uV = 1800000, > + .apply_uV = true, > + .valid_modes_mask = REGULATOR_MODE_NORMAL > + | REGULATOR_MODE_STANDBY, > + .valid_ops_mask = REGULATOR_CHANGE_MODE > + | REGULATOR_CHANGE_STATUS, > + }, > + .num_consumer_supplies = ARRAY_SIZE(ldp_vpll2_supplies), > + .consumer_supplies = ldp_vpll2_supplies, > +}; > > @@ -340,6 +514,7 @@ static struct twl4030_platform_data ldp_twldata = { > .vmmc1 = &ldp_vmmc1, > .gpio = &ldp_gpio_data, > .keypad = &ldp_kp_twl4030_data, > + .vpll2 = &ldp_vpll2, > Right. Do both fixes make it work? If it is, then Tomi, will you add both fixes to the patch set with our SOBs? or do you want this to be sent properly as a follow up? -- Regards, Igor. -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html