On 12/17/24 3:01 PM, Mark Brown wrote:
On Tue, Dec 17, 2024 at 02:45:24PM -0600, Shree Ramamoorthy wrote:
Follow the same naming convention in tps6594-regulator.c with
tpsxxx-regulator instead of tpsxxx-pmic.
static struct platform_driver tps65219_regulator_driver = {
.driver = {
- .name = "tps65219-pmic",
+ .name = "tps65219-regulator",
.probe_type = PROBE_PREFER_ASYNCHRONOUS,
This isn't just a naming convention thing AFACIT, the MFD registers the
new name so the driver wouldn't previously have loaded. How did this
ever work?
It matches based on the platform device .id_table[0] which does have
"tps65219-regulator" listed, the driver .name itself is only used
as a last fallback when there is no .id_table.
[0] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/drivers/base/platform.c#n1352
Andrew