On Wed, 22 May 2019 13:04:46 -0500 "Gustavo A. R. Silva" <gustavo@xxxxxxxxxxxxxx> wrote: > NOTICE THAT: > > "...we don't know whether we need fallthroughs or breaks there and this > is just a change to avoid having new warnings when switching to > -Wimplicit-fallthrough but this change might be entirely wrong."[1] > > See the original thread of discussion here: > > https://lore.kernel.org/patchwork/patch/1036251/ > > So, in preparation to enabling -Wimplicit-fallthrough, this patch silences > the following warnings: > > drivers/mtd/nand/onenand/onenand_base.c: In function ‘onenand_check_features’: > drivers/mtd/nand/onenand/onenand_base.c:3264:6: warning: this statement may fall through [-Wimplicit-fallthrough=] > if (ONENAND_IS_DDP(this)) > ^ > drivers/mtd/nand/onenand/onenand_base.c:3284:2: note: here > case ONENAND_DEVICE_DENSITY_2Gb: > ^~~~ > drivers/mtd/nand/onenand/onenand_base.c:3288:17: warning: this statement may fall through [-Wimplicit-fallthrough=] > this->options |= ONENAND_HAS_UNLOCK_ALL; > drivers/mtd/nand/onenand/onenand_base.c:3290:2: note: here > case ONENAND_DEVICE_DENSITY_1Gb: > ^~~~ > > Warning level 3 was used: -Wimplicit-fallthrough=3 > > This patch is part of the ongoing efforts to enable > -Wimplicit-fallthrough. > > [1] https://lore.kernel.org/lkml/20190509085318.34a9d4be@xps13/ > > Cc: Miquel Raynal <miquel.raynal@xxxxxxxxxxx> > Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx> > --- > drivers/mtd/nand/onenand/onenand_base.c | 2 ++ > 1 file changed, 2 insertions(+) > > diff --git a/drivers/mtd/nand/onenand/onenand_base.c b/drivers/mtd/nand/onenand/onenand_base.c > index f41d76248550..6cf4df9f8c01 100644 > --- a/drivers/mtd/nand/onenand/onenand_base.c > +++ b/drivers/mtd/nand/onenand/onenand_base.c > @@ -3280,12 +3280,14 @@ static void onenand_check_features(struct mtd_info *mtd) > if ((this->version_id & 0xf) == 0xe) > this->options |= ONENAND_HAS_NOP_1; > } > + /* Fall through - ? */ So, the only thing that you'll re-use by falling through the next case is the '->options |= ONENAND_HAS_UNLOCK_ALL' operation. I find it easier to follow with an explicit copy of this line + a break. > > case ONENAND_DEVICE_DENSITY_2Gb: > /* 2Gb DDP does not have 2 plane */ > if (!ONENAND_IS_DDP(this)) > this->options |= ONENAND_HAS_2PLANE; > this->options |= ONENAND_HAS_UNLOCK_ALL; > + /* Fall through - ? */ This fall through certainly doesn't make sense, as the only thing that might be done in the 1Gb case is conditionally adding the HAS_UNLOCK_ALL flag, and this flag is already unconditionally set. Please add a break here. > > case ONENAND_DEVICE_DENSITY_1Gb: > /* A-Die has all block unlock */ ______________________________________________________ Linux MTD discussion mailing list http://lists.infradead.org/mailman/listinfo/linux-mtd/