Problem with serial port access

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Some random bytes are missing while sending data from DOS to Minicom
over a serial cable. I'd appreciate any help. My setup is as follow:

dosemu-1.4.0 on a Fedora 19 x86_64 system, run by root with -s switch.

setserial /dev/ttyS0
/dev/ttyS0, UART: 16650V2, Port: 0xe030, IRQ: 18

cat /etc/dosemu/dosemu.conf
$_com1 = "/dev/ttyS0 irq 18"

(I've also tried without the irq parameter.)

cat /root/.dosemu/drive_c/autoexec.bat
Z:\DOSEMU\SYSTEM.COM stty 9600 -F /dev/ttyS0

>From DOS, I use

mode com1:96,n,8,1

On another machine, I've setup Minicom with the same parameters, and
started it.

>From DOS, I use:

type <file> >com1:

and some bytes are missing from the Minicom output, and the bytes is
different if I run the command once more.

On the machine running DOSEMU, I get the following output with stty -a -F

speed 9600 baud; rows 0; columns 0; line = 0;
intr = <undef>; quit = <undef>; erase = <undef>; kill = <undef>; eof =
eol = <undef>; eol2 = <undef>; swtch = <undef>; start = <undef>; stop =
susp = <undef>; rprnt = <undef>; werase = <undef>; lnext = <undef>;
flush = <undef>; min = 1; time = 0;
-parenb -parodd cs8 -hupcl -cstopb cread clocal -crtscts
ignbrk -brkint ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl -ixon
-iuclc -ixany -imaxbel -iutf8
-opost -olcuc -ocrnl -onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0
bs0 vt0 ff0
-isig -icanon -iexten -echo -echoe -echok -echonl -noflsh -xcase -tostop
-echoctl -echoke

I also has tried to pass crtscts to stty, and then, nothing is sent,
even though I turn on hardware flow control in Minicom.

Minicom to Minicom seems to work properly.

Hope someone can help.

Thanks and regards,
To unsubscribe from this list: send the line "unsubscribe linux-msdos" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at

[Index of Archives]     [Linux Console]     [Linux Audio]     [Linux for Hams]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite Camping]     [Yosemite Hiking]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Samba]     [Linux Media]     [Fedora Users]

  Powered by Linux