2017-11-22 5:14 GMT+09:00 Ulf Hansson <ulf.hansson@xxxxxxxxxx>: > On 21 November 2017 at 21:01, Wolfram Sang <wsa@xxxxxxxxxxxxx> wrote: >> Hi Ulf, >> >> thanks for the feedback! >> >>> So what do you think of this?: >>> >>> 1) Rename tmio_core.c to tmio.c, and fold in some more information >>> about the history of the IP in the header of the file. Yeah, "tmio" >>> may not be the absolutely correct name, but on the other hand it >>> preserves consistency and I there are no need to rename any functions. >>> 2) Rename tmio_mmc.h to tmio.h - and move potential tmio_mmc specific >>> bits to tmio_mmc.c. >>> 3) Rename renesas_sdhi_core.c to tmio_renesas_sdhi.c. Again, I don't >>> think we need any functions to be renamed because of this change. >>> 4) Rename renesas_sdhi.h to tmio_renesas_sdhi.h. >> >> I can agree to that. Clarifying 3), I think though, we should have: >> tmio_sdhi.c >> >> and on top of that: >> >> tmio_sdhi_internal_dmac.c >> tmio_sdhi_sys_dmac.c >> >> ? > > Even better! > >> >>> Following the naming strategy from the above, I the new file name for >>> new tmio variant should be tmio_uniphier.c. >> >> Yes. >> > > Great! > > Br > Uffe > -- > To unsubscribe from this list: send the line "unsubscribe linux-mmc" in > the body of a message to majordomo@xxxxxxxxxxxxxxx > More majordomo info at http://vger.kernel.org/majordomo-info.html In my understanding, TMIO is a name of MFD that includes some built-in peripherals: drivers/usb/host/ohci-tmio.c drivers/mtd/nand/tmio_nand.c If you use "tmio" as a prefix of a group of MMC drivers, it will look odd. # core obj-$(CONFIG_MMC_TMIO) += tmio.o # TMIO-builtin obj-$(CONFIG_MMC_TMIO_MMC) += tmio_mmc.o # Renesas SoCs obj-$(CONFIG_MMC_TMIO_SDHI) += tmio_sdhi.o # UniPhier SoCs obj-$(CONFIG_MMC_TMIO_UNIPHIER) += tmio_uniphier.o This is funny, especially the relation between tmio.o and tmio_mmc.o The "mmc" in the "tmio_mmc.o" is not a platform name. This is even confusing. If we use "tmio_mmc" prefix (like "dw_mmc"), # core obj-$(CONFIG_MMC_TMIO) += tmio_mmc.o # TMIO-builtin MMC obj-$(CONFIG_MMC_TMIO_TMIO) += tmio_mmc_tmio.o # Reneses obj-$(CONFIG_MMC_TMIO_SDHI) += tmio_mmc_sdhi.o # UniPhier obj-$(CONFIG_MMC_TMIO_UNIPHIER) += tmio_mmc_uniphier.o tmio_mmc_tmio.o is a crazy name, but the syntax is clear. The first "tmio_mmc" means the IP name (since we decide this is the right name) The second "tmio" is the platform name the comes from the TMIO MFD. Thought? -- Best Regards Masahiro Yamada -- To unsubscribe from this list: send the line "unsubscribe linux-mmc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html