On 01/31/2014 02:42 PM, David Rientjes wrote: > On Fri, 31 Jan 2014, Vladimir Davydov wrote: > >>> diff --git a/mm/memcontrol.c b/mm/memcontrol.c >>> --- a/mm/memcontrol.c >>> +++ b/mm/memcontrol.c >>> @@ -637,6 +637,9 @@ int memcg_limited_groups_array_size; >>> * better kept as an internal representation in cgroup.c. In any case, the >>> * cgrp_id space is not getting any smaller, and we don't have to necessarily >>> * increase ours as well if it increases. >>> + * >>> + * Updates to MAX_SIZE should update the space for the memcg name in >>> + * memcg_create_kmem_cache(). >>> */ >>> #define MEMCG_CACHES_MIN_SIZE 4 >>> #define MEMCG_CACHES_MAX_SIZE MEM_CGROUP_ID_MAX >>> @@ -3400,8 +3403,10 @@ void mem_cgroup_destroy_cache(struct kmem_cache *cachep) >>> static struct kmem_cache *memcg_create_kmem_cache(struct mem_cgroup *memcg, >>> struct kmem_cache *s) >>> { >>> - char *name = NULL; >>> struct kmem_cache *new; >>> + const char *cgrp_name; >>> + char *name = NULL; >>> + size_t len; >>> >>> BUG_ON(!memcg_can_account_kmem(memcg)); >>> >>> @@ -3409,9 +3414,22 @@ static struct kmem_cache *memcg_create_kmem_cache(struct mem_cgroup *memcg, >>> if (unlikely(!name)) >>> return NULL; >>> >>> + /* >>> + * Format of a memcg's kmem cache name: >>> + * <cache-name>(<memcg-id>:<cgroup-name>) >>> + */ >>> + len = strlen(s->name); >>> + /* Space for parentheses, colon, terminator */ >>> + len += 4; >>> + /* MEMCG_CACHES_MAX_SIZE is USHRT_MAX */ >>> + len += 5; >>> + BUILD_BUG_ON(MEMCG_CACHES_MAX_SIZE > USHRT_MAX); >>> + >> This looks cumbersome, IMO. Let's leave it as is for now. AFAIK, >> cgroup_name() will be reworked soon so that it won't require RCU-context >> (https://lkml.org/lkml/2014/1/28/530). Therefore, it will be possible to >> get rid of this pointless tmp_name allocation by making >> kmem_cache_create_memcg() take not just name, but printf-like format + >> vargs. >> > You believe it's less cumbersome to do two memory allocations to figure > out how much memory you really need to allocate rather than just > calculating the necessary size? Well, I mean not the approach - here everything is right - but how it looks. This len += 4 len += 5 looks scary even with comments, IMHO. Note, I do not stand for this temporary buffer - it was introduced long before I started tweaking this code. I just want to say that substituting it now with something (OK, less, but IMHO still) cumbersome is not a good idea provided soon it will be possible to remove tmp_name while still having the code looking nice. If you insist, I don't mind, but... why? Thanks. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>