Re: [PATCH 06/43] mm: numa: Make pte_numa() and pmd_numa() a generic implementation

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



* Mel Gorman <mgorman@xxxxxxx> wrote:

> That said, your approach just ends up being heavier. [...]

Well, it's more fundamental than just whether to inline or not 
(which I think should be a separate optimization and I won't 
object to two-instruction variants the slightest) - but you 
ended up open-coding change_protection() 
via:

   change_prot_numa_range() et al

which is a far bigger problem...

Do you have valid technical arguments in favor of that 
duplication?

If you just embrace the PROT_NONE reuse approach of numa/core 
then 90% of the differences in your tree will disappear and 
you'll have a code base very close to where numa/core was 3 
weeks ago already, modulo a handful of renames.

It's not like PROT_NONE will go away anytime soon.

PROT_NONE is available on every architecture, and we use the 
exact semantics of it in the scheduler, we just happen to drive 
it from a special worklet instead of a syscall, and happen to 
have a callback to the faults when they happen...

Please stay open to that approach.

Thanks,

	Ingo

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@xxxxxxxxx.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@xxxxxxxxx";> email@xxxxxxxxx </a>


[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]