On Wed, 31 Jul 2024 at 01:10, David Laight <David.Laight@xxxxxxxxxx> wrote: > > The __UNIQUE_ID_() define just seemed excessive - especially > since all compiler versions support __COUNTER__. Yes, we could probably just simplify it. The thing is, "all compiler versions support __COUNTER__" wasn't historically true. We used to have this: /* Not-quite-unique ID. */ #ifndef __UNIQUE_ID # define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __LINE__) #endif because __COUNTER__ is such a new-fangled thing and only got introduced in gcc-4 or something like that. So that "prefix" literally exists because it literally wasn't unique enough without it. And the "__UNIQUE_ID_" thing is probably because that way it was clearer what was going on when something went wrong. But together they really end up being a somewhat unreadable mess. That said, I did end up liking the "prefix" part when looking at expansions, because it helps show "which" expansion it is (ie "x_123" and "y_124" were clearer than just some pure counter value that doesn't have any relationship to the origin at all in the name). But I did change it to "x_" from "__x", because that way it was minimal, yet clearly separate from the counter number (ie "x_123" was better than "__x123"). It was the repeated useless "__UNIQUE_ID_" part of the expansion that ended up annoying. Not quite annoying enough to change it to just "___" or something, but I was close. Linus