On Mon, Jan 31, 2022 at 04:43:32PM -0500, Waiman Long wrote: > > On 1/31/22 15:51, Mike Rapoport wrote: > > On Mon, Jan 31, 2022 at 02:23:07PM -0500, Waiman Long wrote: > > > It was found that a number of offlined memcgs were not freed because > > > they were pinned by some charged pages that were present. Even "echo > > > 1 > /proc/sys/vm/drop_caches" wasn't able to free those pages. These > > > offlined but not freed memcgs tend to increase in number over time with > > > the side effect that percpu memory consumption as shown in /proc/meminfo > > > also increases over time. > > > > > > In order to find out more information about those pages that pin > > > offlined memcgs, the page_owner feature is extended to print memory > > > cgroup information especially whether the cgroup is offlined or not. > > > > > > Signed-off-by: Waiman Long <longman@xxxxxxxxxx> > > > Acked-by: David Rientjes <rientjes@xxxxxxxxxx> > > > --- > > > mm/page_owner.c | 39 +++++++++++++++++++++++++++++++++++++++ > > > 1 file changed, 39 insertions(+) > > > > > > diff --git a/mm/page_owner.c b/mm/page_owner.c > > > index 28dac73e0542..a471c74c7fe0 100644 > > > --- a/mm/page_owner.c > > > +++ b/mm/page_owner.c > > > @@ -10,6 +10,7 @@ > > > #include <linux/migrate.h> > > > #include <linux/stackdepot.h> > > > #include <linux/seq_file.h> > > > +#include <linux/memcontrol.h> > > > #include <linux/sched/clock.h> > > > #include "internal.h" > > > @@ -325,6 +326,42 @@ void pagetypeinfo_showmixedcount_print(struct seq_file *m, > > > seq_putc(m, '\n'); > > > } > > > +#ifdef CONFIG_MEMCG > > > +/* > > > + * Looking for memcg information and print it out > > > + */ > > > +static inline void print_page_owner_memcg(char *kbuf, size_t count, int *pret, > > > + struct page *page) > > > +{ > > > + unsigned long memcg_data = READ_ONCE(page->memcg_data); > > > + struct mem_cgroup *memcg; > > > + bool onlined; > > > + char name[80]; > > > + > > > + if (!memcg_data) > > > + return; > > > + > > > + if (memcg_data & MEMCG_DATA_OBJCGS) > > > + *pret += scnprintf(kbuf + *pret, count - *pret, > > > + "Slab cache page\n"); > > Don't we need to check for overflow here? > > See my previous patch 2 and the reason I used scnprintf() is that it never > return a length that is >= the given size. So overflow won't happen. The > final snprintf() in print_page_owner() will detect buffer overflow. Right, I've missed that > > > + > > > + memcg = page_memcg_check(page); > > > + if (!memcg) > > > + return; > > > + > > > + onlined = (memcg->css.flags & CSS_ONLINE); > > > + cgroup_name(memcg->css.cgroup, name, sizeof(name)); > > > + *pret += scnprintf(kbuf + *pret, count - *pret, > > > + "Charged %sto %smemcg %s\n", > > > + PageMemcgKmem(page) ? "(via objcg) " : "", > > > + onlined ? "" : "offlined ", > > > + name); > > Ditto > > > > > +} > > > +#else /* CONFIG_MEMCG */ > > > +static inline void print_page_owner_memcg(char *kbuf, size_t count, int *pret, > > > + struct page *page) { } > > I think #ifdef inside the print_page_owner_memcg() functions will be > > simpler and clearer. > > Yes, I see both styles used in kernel code though this style is probably > more common. I will keep this unless there is a good reason to do otherwise. Having #ifdef inside the function is safer wrt future updates. It's often happens that non-default arm of #ifdef is forgotten. Besides, it's several lines less. > > > +#endif /* CONFIG_MEMCG */ > > > + > > > static ssize_t > > > print_page_owner(char __user *buf, size_t count, unsigned long pfn, > > > struct page *page, struct page_owner *page_owner, > > > @@ -365,6 +402,8 @@ print_page_owner(char __user *buf, size_t count, unsigned long pfn, > > > migrate_reason_names[page_owner->last_migrate_reason]); > > > } > > > + print_page_owner_memcg(kbuf, count, &ret, page); > > > + > > ret can go over count here. > > Why not make print_page_owner_memcg() an int so that the call will be > > consistent with other calls in print_page_owner(): > > > > ret += print_page_owner_memcg(kbuf, count, page); > > if (ret >= count) > > goto err; I still think that 'int print_page_owner_memcg()' is clearer and more readable. > See my comments above. > > Cheers, > Longman > -- Sincerely yours, Mike.