On 04.04.19 17:40, Oscar Salvador wrote: > On Thu, Apr 04, 2019 at 04:47:43PM +0200, David Hildenbrand wrote: >> On 04.04.19 15:25, Oscar Salvador wrote: >>> On Thu, Apr 04, 2019 at 03:18:00PM +0200, David Hildenbrand wrote: >>>>> diff --git a/mm/memory_hotplug.c b/mm/memory_hotplug.c >>>>> index f206b8b66af1..d8a3e9554aec 100644 >>>>> --- a/mm/memory_hotplug.c >>>>> +++ b/mm/memory_hotplug.c >>>>> @@ -1451,15 +1451,11 @@ static int >>>>> offline_isolated_pages_cb(unsigned long start, unsigned long nr_pages, >>>>> void *data) >>>>> { >>>>> - __offline_isolated_pages(start, start + nr_pages); >>>>> - return 0; >>>>> -} >>>>> + unsigned long offlined_pages; >>>>> >>>>> -static void >>>>> -offline_isolated_pages(unsigned long start_pfn, unsigned long end_pfn) >>>>> -{ >>>>> - walk_system_ram_range(start_pfn, end_pfn - start_pfn, NULL, >>>>> - offline_isolated_pages_cb); >>>>> + offlined_pages = __offline_isolated_pages(start, start + nr_pages); >>>>> + *(unsigned long *)data += offlined_pages; >>>> >>>> unsigned long *offlined_pages = data; >>>> >>>> *offlined_pages += __offline_isolated_pages(start, start + nr_pages); >>> >>> Yeah, more readable. >>> >>>> Only nits >>> >>> About the identation, I double checked the code and it looks fine to me. >>> In [1] looks fine too, might be your mail client? >>> >>> [1] https://patchwork.kernel.org/patch/10885571/ >> >> Double checked, alignment on the parameter on the new line is very weird. > > Uhm, are not you confused because we removed the "while (off...)", and > "ret =" gets idented right below "/*check again*". > > Try to apply the patch and check whether you still see the issue. > I just checked out the branch and it looks fine to me. That's what I did and it hurts my eyes (dropping two tabs, converting tabs to spaces) your patch: ret = walk_system_ram_range(start_pfn, end_pfn - start_pfn, NULL, check_pages_isolated_cb); vs. ret = walk_system_ram_range(start_pfn, end_pfn - start_pfn, NULL, check_pages_isolated_cb); Just so we are on the same page, we usually indent parameters on additional lines to the start of other parameters. Not to the end of the previous line. > >> And both lines cross 80 lines per line ... nit :) > > Yeah, 81 characters, but I decided to go with that rather than start doing > tricky things to accomplish 80 characters. > Maybe Andrew agrees, or he might slap me. > Why not simply ret = walk_system_ram_range(start_pfn, end_pfn - start_pfn, NULL, check_pages_isolated_cb); just as we have in add_memory_resource along with walk_memory_range(). A lot of nit-picking, sorry :) -- Thanks, David / dhildenb