Re: [PATCH 6/6] Add comment in alloc_pages_exact_node

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Apr 14, 2010 at 12:25:03AM +0900, Minchan Kim wrote:
> alloc_pages_exact_node naming makes some people misleading.
> They considered it following as.
> "This function will allocate pages from node which I wanted
> exactly".
> But it can allocate pages from fallback list if page allocator
> can't find free page from node user wanted.
> 
> So let's comment this NOTE.
> 

It's a little tough to read. How about

/*
 * Use this instead of alloc_pages_node when the caller knows
 * exactly which node they need (as opposed to passing in -1
 * for current). Fallback to other nodes will still occur
 * unless __GFP_THISNODE is specified.
 */

That at least will tie in why "exact" is in the name?

> Actually I wanted to change naming with better.
> ex) alloc_pages_explict_node.

"Explicit" can also be taken to mean "this and only this node".

> But I changed my mind since the comment would be enough.
> 
> If anybody suggests better name, I will do with pleasure.
> 
> Cc: Mel Gorman <mel@xxxxxxxxx>
> Cc: KAMEZAWA Hiroyuki <kamezawa.hiroyu@xxxxxxxxxxxxxx>
> Cc: Bob Liu <lliubbo@xxxxxxxxx>
> Signed-off-by: Minchan Kim <minchan.kim@xxxxxxxxx>
> ---
>  include/linux/gfp.h |    5 +++++
>  1 files changed, 5 insertions(+), 0 deletions(-)
> 
> diff --git a/include/linux/gfp.h b/include/linux/gfp.h
> index b65f003..7539c17 100644
> --- a/include/linux/gfp.h
> +++ b/include/linux/gfp.h
> @@ -288,6 +288,11 @@ static inline struct page *alloc_pages_node(int nid, gfp_t gfp_mask,
>  	return __alloc_pages(gfp_mask, order, node_zonelist(nid, gfp_mask));
>  }
>  
> +/*
> + * NOTE : Allow page from fallback if page allocator can't find free page
> + * in your nid. Only if you want to allocate page from your nid, use
> + * __GFP_THISNODE flags with gfp_mask.
> + */
>  static inline struct page *alloc_pages_exact_node(int nid, gfp_t gfp_mask,
>  						unsigned int order)
>  {
> -- 
> 1.7.0.5
> 

-- 
Mel Gorman
Part-time Phd Student                          Linux Technology Center
University of Limerick                         IBM Dublin Software Lab

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@xxxxxxxxxx  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@xxxxxxxxx";> email@xxxxxxxxx </a>

[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]