Hi Geert,
-static struct platform_device *atari_ethernec_devices[] __initdata = {
- &rtl8019_device
Oops, removal of atari_ethernec_devices?
Superseded by atari_netusbee_devices which holds both ethernet and usb
platform data:
+static struct platform_device *atari_netusbee_devices[] __initdata = {
+ &rtl8019_device,
+ &netusbee_device
};
Sorry, I missed that. You want to update the help text for ATARI_ETHERNEC.
Right - and maybe come up with a better name for the option -
ATARI_ROM_PORT_DEVICES?
BTW, wouldn't it better to rename netusbee_device to isp116x_device, cfr.
rtl8019_device?
We already have isp1160_device - maybe I'll have to rename that to
isp116x_ethernat_device, and the other one can be isp116x_netusbee_device?
What's the practical limit for these device/struct names?
I'll have to check that CONFIG_ATARI_ETHERNEC is selected when either ne.c
or isp116x driver are selected. It might otherwise be possible to select the
USB driver only, and not the ethernet one, resulting in a nonfunctional
driver.
ATARI_USB should depend on ...?
Either ATARI_ETHERNAT or ATARI_ETHERNEC, in practice. Not sure I'm building
a kconfig dependency loop - can I rely on things set in Kconfig.devices when
defining ATARI_USB in Kconfig.bus?
I'll also have to change the help text for ATARI_ETHERNAT to include the USB
function.
Getting there, I'm sure.
Cheers,
Michael
--
To unsubscribe from this list: send the line "unsubscribe linux-m68k" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html