On Thu, Feb 20, 2020 at 12:57 PM Uwe Kleine-König <u.kleine-koenig@xxxxxxxxxxxxxx> wrote: > On Thu, Feb 20, 2020 at 12:22:36PM +0200, Andy Shevchenko wrote: > > On Thu, Feb 20, 2020 at 9:49 AM Uwe Kleine-König > > <u.kleine-koenig@xxxxxxxxxxxxxx> wrote: > > > On Wed, Feb 19, 2020 at 09:50:54PM +0200, Andy Shevchenko wrote: > > > > On Thu, Feb 13, 2020 at 11:27 AM Uwe Kleine-König <uwe@xxxxxxxxxxxxxxxxx> wrote: > > > > > > > > > > This function is in the same spirit as the other kstrto* functions and > > > > > uses the same calling convention. It expects the input string to be in > > > > > the format %u:%u and implements stricter parsing than sscanf as it > > > > > returns an error on trailing data (other than the usual \n). > > > > ... > > > > > > On top of that, why kstrtodev_t is so important? How many users are > > > > already in the kernel to get an advantage out of it? > > > > > > Does it need to be important? It matches the other kstrto* functions and > > > so it seemed more natural to me to put it near the other functions. I'm > > > not aware of other potential users and surprised you seem to suggest > > > this as a requirement. > > > > Yes it does. The kstrtox() are quite generic, what you are proposing > > is rather one particular case with blurry understanding how many users > > will be out of it. > > In my understanding one user is a hard requirement. Yes. But looking at the LOCs you introduce to entire kernel in such generic area (I wouldn't tell you anything if, for instance, you introduced a support for hypothetical S2P bus with one host controller driver) like lib/. > > If you had told "look, we have 1234 users which may benefit out of > > it", I would have given no comment against. > > Sure, having >1000 potential users would be a good argument pro this > function. But having only one isn't a good contra IMHO. For lib/ is a good argument in my opinion. > > > > What to do with all other possible variants ("%d:%d", "%dx%d" and its > > > > %u variant, etc)? > > > > > > I don't see how %d:%d is relevant, major and minor cannot be negative > > > can they? I never saw 'x' as separator between major and minor. I > > > considered shortly parsing %u, but given that (I think) this is an > > > internal representation only I chose to not make it more visible than it > > > already is. > > > > See above, if we are going to make it generic, perhaps better to cover > > more possible users, right? > > Otherwise your change provokes pile of (replaced) > > kstrto_resolution() /* %ux:%u */ > > kstrto_range() /* %d:%d */ > > kstrto_you_name_it() > > Given there are respective types that this can be stored to, I don't > object more functions of this type and don't see a good reason to not > add such a function. And in my eyes I prefer to have such a function in > a visible place (i.e. where all the other kstrto* functions are) to > prevent code duplication. You can easily satisfy above by adding a function parameter 'char *delim', right? > Also I don't understand yet, what you want me to do. I have issues with kstrto() not playing with simple numbers (boolean is a special case, but still a number at the end). I also don't feel good with too narrow usage of the newly introduced helper > Assume I'd be > willing to use simple_strtoul, I'd still want to have a function that > gives me a dev_t from a given string. Should I put this directly in my > led-trigger driver? I see the following possibilities: a) put it inside the caller and forget about generic helper b) do a generic helper, but 1/ in string_*() namespace, 2/ with a delimiter parameter and 3/ possibility to take negative numbers In b) case, add to the commit message how many potential _existing_ users may be converted to this. Also it would be good to have two versions strict (only \n at the end is allowed) and non-strict (based on the amount of users for each group). > > > And given that I was asked for strict > > > parsing (i.e. not accepting 2:4:something) I'd say using simple_strto* > > > is a step backwards. Also simple_strtoul() has "This function is obsolete. > > > Please use kstrtoul instead." in its docstring which seems to apply to > > > the other simple_strto*() functions, too. > > > > I specifically fixed a doc string to approve its use in the precisely > > cases you have here. > > Can you please be a bit more constructive here and point to the change > you talk about? I didn't find a commit in next. https://elixir.bootlin.com/linux/v5.6-rc2/source/include/linux/kernel.h#L446 Note, there is no more word 'obsolete' there. -- With Best Regards, Andy Shevchenko