Re: [PATCH] leds: is31fl32xx: Use struct_size() helper

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Gustavo,

Thank you for the patch.

On 8/30/19 8:14 PM, Gustavo A. R. Silva wrote:
> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
> 
> struct is31fl32xx_priv {
> 	...
>         struct is31fl32xx_led_data leds[0];
> };
> 
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes.
> 
> So, replace the following function:
> 
> static inline size_t sizeof_is31fl32xx_priv(int num_leds)
> {
>        return sizeof(struct is31fl32xx_priv) +
>                      (sizeof(struct is31fl32xx_led_data) * num_leds);
> }
> 
> with:
> 
> struct_size(priv, leds, count)
> 
> This code was detected with the help of Coccinelle.
> 
> Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx>
> ---
>  drivers/leds/leds-is31fl32xx.c | 8 +-------
>  1 file changed, 1 insertion(+), 7 deletions(-)
> 
> diff --git a/drivers/leds/leds-is31fl32xx.c b/drivers/leds/leds-is31fl32xx.c
> index 6fbab70dfb04..6f29b8943913 100644
> --- a/drivers/leds/leds-is31fl32xx.c
> +++ b/drivers/leds/leds-is31fl32xx.c
> @@ -324,12 +324,6 @@ static int is31fl32xx_init_regs(struct is31fl32xx_priv *priv)
>  	return 0;
>  }
>  
> -static inline size_t sizeof_is31fl32xx_priv(int num_leds)
> -{
> -	return sizeof(struct is31fl32xx_priv) +
> -		      (sizeof(struct is31fl32xx_led_data) * num_leds);
> -}
> -
>  static int is31fl32xx_parse_child_dt(const struct device *dev,
>  				     const struct device_node *child,
>  				     struct is31fl32xx_led_data *led_data)
> @@ -450,7 +444,7 @@ static int is31fl32xx_probe(struct i2c_client *client,
>  	if (!count)
>  		return -EINVAL;
>  
> -	priv = devm_kzalloc(dev, sizeof_is31fl32xx_priv(count),
> +	priv = devm_kzalloc(dev, struct_size(priv, leds, count),
>  			    GFP_KERNEL);
>  	if (!priv)
>  		return -ENOMEM;
> 

Applied.

-- 
Best regards,
Jacek Anaszewski



[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux