Based on Fix: a69eeaad093d "iio: humidity: hdc3020: fix temperature offset" in branch fixes-togreg Changes in V2: - Fix alphabetical order of includes(Christophe) - Fix typo: change varibale name "HDC3020_R_R_RH_THRESH_LOW_CLR" to HDC3020_R_T_RH_THRESH_LOW_CLR to match variable name pattern(Christophe) - Add constants HDC3020_MIN_TEMP and HDC3020_MAX_TEMP for min/max threshold inputs (Christophe) - Change HDC3020_MIN_TEMP to -40, as stated in the datasheet(Javier) Changes in V3: - drop u8 register pairs and switch to 16bit defines(Jonathan) - create helper functions to avoid code duplication(Jonathan) - Add interrupt bindings in example - use the decimal part for setting thresholds(Javier) - use return in switch cases hdc3020_read_thresh(Jonathan) - fix interrupt handler:(Jonathan) - return IRQ_HANDLED when we get a read back failure - take the timestamp into a local variable - fix multiline comments(Jonathan) - use fixed value "hdc3020" instead of dev_id in probe - clear interrupt after registering the interrupt handler - remove interrupt polarity Dimitri Fedrau (3): iio: humidity: hdc3020: drop u8 register pairs dt-bindings: iio: humidity: hdc3020: add interrupt bindings in example iio: humidity: hdc3020: add threshold events support .../bindings/iio/humidity/ti,hdc3020.yaml | 2 + drivers/iio/humidity/hdc3020.c | 443 ++++++++++++------ 2 files changed, 309 insertions(+), 136 deletions(-) -- 2.39.2