On Wed, 7 Dec 2022 15:37:40 +0800 (CST) <ye.xingchen@xxxxxxxxxx> wrote: > From: ye xingchen <ye.xingchen@xxxxxxxxxx> > > Follow the advice of the Documentation/filesystems/sysfs.rst and show() > should only use sysfs_emit() or sysfs_emit_at() when formatting the > value to be returned to user space. > > Signed-off-by: ye xingchen <ye.xingchen@xxxxxxxxxx> > --- > drivers/iio/health/afe440x.h | 4 +--- > 1 file changed, 1 insertion(+), 3 deletions(-) > > diff --git a/drivers/iio/health/afe440x.h b/drivers/iio/health/afe440x.h > index 0adea0047eba..7750b1adc423 100644 > --- a/drivers/iio/health/afe440x.h > +++ b/drivers/iio/health/afe440x.h > @@ -122,9 +122,7 @@ static ssize_t _name ## _show(struct device *dev, \ > int i; \ > \ > for (i = 0; i < ARRAY_SIZE(_table); i++) \ > - len += scnprintf(buf + len, PAGE_SIZE - len, "%d.%06u ", \ > - _table[i].integer, \ > - _table[i].fract); \ > + len += sysfs_emit_at(buf, len, "%d.%06u ", _table[i].integer, _table[i].fract); \ Please keep to the shorter original wrapping on this. It's fine to go above 80 chars (below 100) if it makes a significant improvement to readability. I don't think that's true here, so better to stick to the shorter length. > \ > buf[len - 1] = '\n'; \ > \