Version 2 of https://lkml.org/lkml/2015/11/25/245 * fix few typos, comments and return value type issues. * fix remove function: call order for iio_device_unregister * rename itb => int_time_vbus and its => int_time_vshunt for clarity * fix scale for integr. times (available values where in uS instead of s) * move static variable into device data to allow for multiple instances previous references: following RFC started in https://lkml.org/lkml/2015/11/10/370 and feed back from https://lkml.org/lkml/2015/11/18/395 Marc Titinger (2): iio: ina2xx: add support for TI INA2xx Power Monitors iio: ina2xx: provide a sysfs parameter to allow async readout of the ADCs drivers/iio/adc/Kconfig | 9 + drivers/iio/adc/Makefile | 1 + drivers/iio/adc/ina2xx-iio.c | 714 +++++++++++++++++++++++++++++++++++++++++++ 3 files changed, 724 insertions(+) create mode 100644 drivers/iio/adc/ina2xx-iio.c -- 1.9.1 -- To unsubscribe from this list: send the line "unsubscribe linux-iio" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html