Jeff Garzik <jgarzik@xxxxxxxxx> writes: > > diff --git a/drivers/ata/pata_cs5536.c b/drivers/ata/pata_cs5536.c > > index 88a7933..0898213 100644 > > --- a/drivers/ata/pata_cs5536.c > > +++ b/drivers/ata/pata_cs5536.c > > @@ -232,7 +232,7 @@ static struct scsi_host_template cs5536_sht = { > > }; > > > > static struct ata_port_operations cs5536_port_ops = { > > - .inherits =&ata_bmdma_port_ops, > > + .inherits =&ata_bmdma32_port_ops, > > .cable_detect = cs5536_cable_detect, > > .set_piomode = cs5536_set_piomode, > > .set_dmamode = cs5536_set_dmamode, > > applied Why not rename ata_bmdma_port_ops as ata_bmdma_port_ops16 for consistency? -- To unsubscribe from this list: send the line "unsubscribe linux-ide" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html