On Friday 11 January 2008, Borislav Petkov wrote: > That is, > - remove unnecessary comments > - shorten comments > - shorten lines longer 80 columns > - cleanup whitespace > - add a missing loglevel KERN_ to a printk-call > - fix misc checkpatch warnings Majority of this patch consists of checkpatch.pl fixes so it should be merged with patch #20. Also a lot of code beautified here is _heavily_ modified in later patches so some of fixups below could be moved there (which would also decrease the size of this patch significantly). > Signed-off-by: Borislav Petkov <bbpetkov@xxxxxxxx> > --- > drivers/ide/ide-floppy.c | 402 +++++++++++++++++++++------------------------- > 1 files changed, 181 insertions(+), 221 deletions(-) [...] > +#define PC_ABORT 0 /* Set when an error is considered\ > + normal - We won't retry */ '\' shouldn't be there and /* ... */ #define PC_ABORT 0 would be probably more readable > +#define PC_DMA_RECOMMENDED 2 /* DMA use preferred, if possible */ please make it match the other flags while at it (space -> tab) [...] > -#define IDEFLOPPY_USE_READ12 2 /* Use READ12/WRITE12 or READ10/WRITE10 */ > +#define IDEFLOPPY_USE_READ12 2 /* READ(10|12)/WRITE(10|12) */ The original comment was way more informative. Moreover this particular flag is never set so it could be just removed (together with some dead code for handling it) in a separate (pre-)patch. > #define IDEFLOPPY_FORMAT_IN_PROGRESS 3 /* Format in progress */ please make it match the other flags while at it (tab -> space) > -#define IDEFLOPPY_CLIK_DRIVE 4 /* Avoid commands not supported in Clik drive */ > -#define IDEFLOPPY_ZIP_DRIVE 5 /* Requires BH algorithm for packets */ > +#define IDEFLOPPY_CLIK_DRIVE 4 /* Avoid commands not supported\ > + in Clik drive */ > +#define IDEFLOPPY_ZIP_DRIVE 5 /* Requires BH algorithm for\ > + packets */ no need for '\' characters [...] > -static void idefloppy_queue_pc_head (ide_drive_t *drive,idefloppy_pc_t *pc,struct request *rq) > +static void idefloppy_queue_pc_head(ide_drive_t *drive, idefloppy_pc_t *pc, > + struct request *rq) minor CodingStyle nitpick: static void idefloppy_queue_pc_head(ide_drive_t *drive, idefloppy_pc_t *pc, struct request *rq) would be more readable IMO but it is a matter of personal taste [ same applies for other similar modifications done by this patch series ] - To unsubscribe from this list: send the line "unsubscribe linux-ide" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html