Hi Ben, On Mon, Jul 20, 2009 at 11:06 PM, Ben Dooks<ben-linux@xxxxxxxxx> wrote: >> + >> +static struct dev_pm_ops au1xpsc_smbus_pmops = { >> + .resume = i2c_au1550_resume, >> + .suspend = i2c_au1550_suspend, >> +}; >> >> static struct platform_driver au1xpsc_smbus_driver = { >> .driver = { >> .name = "au1xpsc_smbus", >> .owner = THIS_MODULE, >> + .pm = &au1xpsc_smbus_pmops, > > hmm, why not > .pm = (struct dev_pm_ops &) { > .suspend = ..., > .resume = ..., > }, > > ? I remember one patch being shot down on account of having this style. I prefer the original style too, but I've no objections to changing it... Thank you! Manuel Lauss -- To unsubscribe from this list: send the line "unsubscribe linux-i2c" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html