> > @@ -976,17 +976,22 @@ find_primary_channel_by_offer(const struct > > vmbus_channel_offer_channel *offer) > > return channel; > > } > > > > -static bool vmbus_is_valid_device(const guid_t *guid) > > +static bool vmbus_is_valid_offer(const struct vmbus_channel_offer_channel *offer) > > { > > + const guid_t *guid = &offer->offer.if_type; > > u16 i; > > > > if (!hv_is_isolation_supported()) > > return true; > > > > + if (is_hvsock_offer(offer)) > > + return true; > > + > > for (i = 0; i < ARRAY_SIZE(vmbus_devs); i++) { > > if (guid_equal(guid, &vmbus_devs[i].guid)) > > return vmbus_devs[i].allowed_in_isolated; > > } > > + > > Spurious newline added? > > > return false; Intentionally added to visually separate the "hvsock", "vmbus_dev" and "default" blocks, patch seemed simple enough to try to merge in "style material" without incurring in the question. ;-) Newline removed. Thanks, Andrea